Back to overview
Downtime
Downloads are unavailable
May 10, 2026 at 4:16am UTC
Affected services
Downloads
Resolved
May 10, 2026 at 5:12am UTC
The file download service was down between 06:08 and 07:10 CEST following a node storage issue. The issue has been resolved and the service is back online.
Affected services
Created
May 10, 2026 at 4:16am UTC
Download server is currently down. We are expecting it to be online again within 30 minutes.
Affected services