Back to overview
Resolved
Downloads Service degraded
Jul 5, 2026 at 11:12pm UTC
Affected services
Downloads
Resolved
Jul 6, 2026 at 6:17am UTC
We identified an issue where the downloads endpoint remained reachable, but was presenting an invalid SSL/TLS certificate. This could have caused certificate warnings or prevented secure downloads for some users.
The certificate has been corrected, and downloads are now operating normally over a valid secure connection.
We apologize for any inconvenience and appreciate your patience.
Affected services
Created
Jul 5, 2026 at 11:12pm UTC
Download endpoint certificate issue due to invalid website certificate. Downloads is still reachable but shows an certificate expired issue.
Affected services